VLAN: 虚拟局域网

  • 时间:
  • 浏览:
  • 来源:互联网

VLAN: 虚拟局域网

将交换机逻辑划分成多个广播域
配置思路

1、交换机上创建VLAN
2、交换机上的接口划分到对应VLAN
3、Trunk干道,,,SW-SW SW-RT
4、VLAN间路由 路由器子接口(单臂路由) 多层交换机

配置命令

1、创建VLAN
	VLAN编号  0-4095  其中1-4094可用;默认存在VLAN1,且所有接口均属于VLAN1

#创建单个VLAN
[sw1]vlan 2
[sw1]vlan 3


#描述VLAN
[sw1-vlan2]description yunjisuan

#创建多个连续VLAN
[sw1]vlan batch 3 to 10

#花样创建VLAN
[sw1]vlan batch 11 to 20 22

#查看VLAN
[sw1]dis vlan

#删除VLAN
[sw1]undo vlan batch 3 to 20 22

2、划分交换机接口到VLAN中

#进入接口
[sw1]int g0/0/1

#修改端口类型
[sw1-GigabitEthernet0/0/1]port link-type access 

#配置接口默认VLAN
[sw1-GigabitEthernet0/0/1]port default vlan 2

#批量修改接口
[sw1]port-group group-member GigabitEthernet 0/0/3 to GigabitEthernet 0/0/4

#输入以下指令
[sw1-port-group]port link-type access 

#显示以下内容
[sw1-GigabitEthernet0/0/3]port link-type access 
[sw1-GigabitEthernet0/0/4]port link-type access 

#执行以下指令
[sw1-port-group]port default vlan 3

#显示以下输出
[sw1-GigabitEthernet0/0/3]port default vlan 3
[sw1-GigabitEthernet0/0/4]port default vlan 3


#交换机SW2配置

#创建vlan
[sw2]vlan batch 2 to 3

[sw2]int g0/0/1
[sw2-GigabitEthernet0/0/1]port link-type access 
[sw2-GigabitEthernet0/0/1]port default vlan 2
[sw2-GigabitEthernet0/0/1]int g0/0/2
[sw2-GigabitEthernet0/0/2]port link-type access 
[sw2-GigabitEthernet0/0/2]port default vlan 3

3、Trunk干道
不属于任何一个VLAN,承载所有VLAN流量传递,标记和区分VLAN标签,华为默认trunk仅允许VLAN1通过

#进入接口
[sw1]int g0/0/24

#修改接口类型
[sw1-GigabitEthernet0/0/24]port link-type trunk 

#修改默认通过所有VLAN
[sw1-GigabitEthernet0/0/24]port trunk allow-pass vlan all
#也可以使用以下命令
[sw1-GigabitEthernet0/0/24]port trunk allow-pass vlan 2 to 3

[sw2]interface GigabitEthernet 0/0/24
[sw2-GigabitEthernet0/0/24]port link-type trunk 
[sw2-GigabitEthernet0/0/24]port trunk allow-pass vlan all


cisco的trunk干道上存在ISL私有标记技术和802.1q公有标记技术,其他厂商使用公有 也称dot1.q

4、VLAN间路由
在一个物理接口上,逻辑配置多个虚拟接口,来识别和标记不同VLAN的流量,为不同的VLAN网段进行路由工作

#连接路由器的交换机接口配置
[sw1]int g0/0/23
[sw1-GigabitEthernet0/0/23]port link-type trunk 
[sw1-GigabitEthernet0/0/23]port trunk allow-pass vlan all 

#路由器子接口配置
[r1]int g0/0/0.1
[r1-GigabitEthernet0/0/0.1]dot1q termination vid 2

#启用接口arp响应,华为设备默认不进行ARP响应
[r1-GigabitEthernet0/0/0.1]arp broadcast enable 

#配置子接口IP地址
[r1-GigabitEthernet0/0/0.1]ip ad 192.168.1.254 24

#子接口0.2配置
[r1-GigabitEthernet0/0/0.1]int g0/0/0.2
[r1-GigabitEthernet0/0/0.2]dot1q termination vid 3
[r1-GigabitEthernet0/0/0.2]arp broadcast enable 
[r1-GigabitEthernet0/0/0.2]ip ad 192.168.2.254 24

#配置DHCP
[r1]dhcp enable 
[r1]ip pool v2
[r1-ip-pool-v2]network 192.168.1.0 mask 255.255.255.0 
[r1-ip-pool-v2]gateway-list 192.168.1.254
[r1-ip-pool-v2]dns-list 114.114.114.114 8.8.8.8
[r1-ip-pool-v2]q

[r1]ip pool v3
[r1-ip-pool-v3]network 192.168.2.0 mask 255.255.255.0
[r1-ip-pool-v3]gateway-list 192.168.2.254
[r1-ip-pool-v3]dns-list 114.114.114.114 8.8.8.8
[r1-ip-pool-v3]q

[r1]interface  g0/0/0.1
[r1-GigabitEthernet0/0/0.1]dhcp select global 
[r1-GigabitEthernet0/0/0.1]int g0/0/0.2
[r1-GigabitEthernet0/0/0.2]dhcp select global 

本文链接http://www.dzjqx.cn/news/show-617177.html